Welcome to MonsterFishKeepers.com

The members of this forum have come together to share our knowledge and experiences of fish keeping. We want to answer your questions, offer advice and fill the galleries with pictures of the fish we have all grown to love.

We are a unique community of Fish Keepers who seriously take our hobby to extremes and the NEXT level. The majority of our fish collections include RARE & EXOTIC Species of all sizes, BIG FISH with BIG APPETITES and BIG TANKS. It's not easy for most people or other "regular" fish keepers to understand why we maintain this type of collection and spare no expense on this fascinating hobby.

Hopefully, through this site and discussion forums we can encourage the next generation of Monster Fish Keepers to have the same passion and love we have for the hobby and our Monster Fish .

As one of the founding members, I personally invite you to register and join us today. Currently you are viewing this site as our guest which only gives you limited access to view most discussions, articles and photo galleries.

Registration is FREE and very easy! When you register, you'll have instant access to....

  • • Post and participate in discussions about your passion for fish keeping
  • • Have your own Photo Gallery and the ability to upload your images
  • • View and comment on the gallery
  • • Participate in MFK contests, promotions, and discounts
  • • Use of private messaging to communicate with other community members


  • We're constantly striving to improve our community to help make your Monster Fish Keeping hobby fulfilling and interesting. Comments are welcome.


    WE ARE MONSTER FISH KEEPERS!

    -MFK STAFF



    Sign Up
    1. Please double check and update your email --> http://www.monsterfishkeepers.com/forums/index.php?account/contact-details

    Noisy Aquaclear 70- solutions?

    Discussion in 'Setup and Filtration' started by fwiffo, Nov 17, 2009.

    1. fwiffo

      fwiffo MFK Members

      Joined:
      Dec 5, 2007
      Messages:
      163
      Likes Received:
      0
      Trophy Points:
      0
      Location:
      USA
      Last Seen:
      Mar 4, 2015
      hey- i just bought an aquaclear 70 off ebay new for 38 bucks.
      it runs good and is very strong on my tank, but it's noisy.
      the impeller is loud.
      i have an aquaclear 50 and it is whisper silent, no noise from the impeller at all.
      is this noise temporary, like the motor and impeller are breaking themselves in?
      also,the hood was rattling, so i removed it. any ideas on what the problem is?

      by the way, what media setup do you fellows use? it came with a foam, carbon , and clay rings, but those only take up like 1/2 the media basket!!! so what do you guys do?

      thanks!!
       
    2. knicks791

      knicks791 MFK Members

      Joined:
      Sep 22, 2009
      Messages:
      752
      Likes Received:
      0
      Trophy Points:
      0
      Occupation:
      Analyst
      Location:
      yonkers ny
      Last Seen:
      Apr 30, 2014
      Its happened to me before.... it will go away eventually. Just make sure the water line is correct.
       
    3. mr.reef24

      mr.reef24 MFK Leaders
      Staff Member

      Joined:
      Apr 21, 2009
      Messages:
      4,457
      Likes Received:
      0
      Trophy Points:
      0
      Occupation:
      Bio Student, and Manager, Also run 2 business's
      Location:
      USA
      Last Seen:
      Apr 4, 2015
      sounds like the impeller is clogged or need's clean or is sucking in air

      mr.reef24
       
    4. synspilus guy

      synspilus guy MFK Members

      Joined:
      Oct 3, 2009
      Messages:
      52
      Likes Received:
      0
      Trophy Points:
      0
      Location:
      arizona
      Last Seen:
      Jan 16, 2011
      I bought a used ac110 about a year ago. It sounded like a freight train. It took a few weeks to quiet down. Actually the first thing I did was replace the impeller. That helped a bit. It seems like after a few weeks of developing some slime in the filter it helps cushion things and quiet it down. I've taken it out of my system before and when started using it again it was noisy. After about 1 to 2 weeks of running its quiet again.
       
    5. KaiserSousay

      KaiserSousay MFK Members

      Joined:
      Feb 20, 2009
      Messages:
      1,230
      Likes Received:
      0
      Trophy Points:
      0
      Occupation:
      retired maintenance mechanic
      Location:
      PartlyCloudyFlorida
      Last Seen:
      Dec 25, 2011
      99.9 noise from a HOB is impeller.
      What else on them moves???
      A scored, grooved shaft. A slightly bent shaft. Impeller/magnet assembly slightly tight on the shaft, or too loose. An out of balance assembly.
      You can help "break them in" by pulling the assembly off of the shaft and use some silicone (aquarium safe) grease on the shaft. I have found this stuff at Ace hardware and is good stuff to have on hand.
      Works for me.
       
    6. fwiffo

      fwiffo MFK Members

      Joined:
      Dec 5, 2007
      Messages:
      163
      Likes Received:
      0
      Trophy Points:
      0
      Location:
      USA
      Last Seen:
      Mar 4, 2015
      sounds like good ideas. i'll check out the impeller and shaft tomorrow. i have become compalcent with the ease of making my own filters that are a breeze to operate and are silent. these aquaclears need more work!!! i'll check it out though with the impeller, maybe there is something in there. the sound is like a very mild grinding noise.
       

    Share This Page